Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: My Township won't load . . .

  1. #1
    CW Pearson
    Guest

    My Township won't load . . .

    Just started this morning. I tap the township icon and it goes through the process then closes back to my home screen. Tried resetting, turning on and off, going in through other means, etc. Nothing working. I really don't want to have to start all over after getting to level 57 . . . ?

  2. #2
    Lindsey Dehmler
    Guest
    I'm having the same issue on my kindle. I've restarted my device and checked all the settings. The game will load until it says "connecting" and kick me back to my home screen. Other games that run on GameCircle work fine, so it's got to be something wrong with the game.

    Edit: I just realized that this issue is being addressed on the "Announcements" thread.
    Last edited by Lindsey Dehmler; 08-11-2015 at 08:00 PM.

  3. #3
    debrandw246
    Guest
    Mine is on a Kindle. Same issue. Starts to connect, then throws me off.

  4. #4
    Please follow this thread to know what to do and what Playrix is doing about it :

    http://forum.playrix.com/showthread....dle%29-UPDATED
    Graylady, Forum member since may 2014 --- Playing on Android, not on Facebook
    Township level 206, Zoo 194 animals, --- coop #HHPY84

    Please read this important post by Playrix about Township : Wishes/requests already rejected by Playrix

  5. #5
    Bennlexx
    Guest
    Having the same problem this morning on a Galaxy Tab S after an android update.

  6. #6
    Bennlexx
    Guest
    Clearing the cache didn't help. Will wait until tomorrow before going down the path of deleting and re installing.

  7. #7
    momasparagus
    Guest
    I tried clearing cache; didn't help at all. Uninstalled after reading that it would "NOT affect" my progress, and had to start over from the very beginning. Extremely frustrated for a couple of reasons: (1) I was on a time deadline which I was all set to meet, and (2) I spent my Amazon coins to help me advance in the game. I would like my progress restored or a refund on my coins. If one of those things doesn't happen, I can't see me bothering to play this game anymore. Someone should definitely update to say that you might lose your progress instead of you will NOT lose your progress. Very disappointed in this entire situation.

  8. #8
    Hayley Bishop
    Guest
    Same here .....starts to load then takes me back to home screen I'm on kindle also. I emailed them and they said it will be sorted in a few days and they are aware of the problem.

  9. #9
    Cassandra Lloyd
    Guest
    I am having the same problem on my kindle as well! I have spent money on advancing my game and I am also waiting for time activated quests to complete as well as other time sensitive issues. I really hope this can be resolved asap.

  10. #10
    Pam Laven
    Guest
    Quote Originally Posted by debrandw246 View Post
    Mine is on a Kindle. Same issue. Starts to connect, then throws me off.
    I'm having same problem! Frustrating!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •