I have a new Amazon Fire tablet 7 kids edition and I'm having trouble getting Township to load on any of the kid profiles on this tablet. The progress bar on the Township splash screen fills up but it never loads the game. The splash screen animation continues to run the animations though so it isn't freezing up. It also shows the standard loading screen and not the spring themed one with the flowers.

I can get the game to load on the parent profiles and I have other Fire tablets where the game will load on the kid's profiles.

I've tried everything from clearing the cache, force closing, reinstalling the game, clearing data, resetting to factory default, and checking for updates to the game and tablet but nothing seems to work. I've even tried making a brand new kid profile but that didn't seem to work either. I've added Township in the Add content of the FreeTime profile and I've also tried enabling in-app purchases and the web browser even though these aren't enabled on the other tablets where the game loads. This is a brand new tablet with nothing else on it so no storage issues.

Any one else have issues getting the game to load on the Amazon FreeTime kids profiles?