Page 3 of 3 FirstFirst 123
Results 21 to 29 of 29

Thread: Game won’t open, stuck on “loading”

  1. #21
    Junior Member
    Join Date
    Jul 2016
    Location
    Victoria, Australia
    Posts
    88
    On my laptop I have 4GB of memory and over 60GB of space.
    I have done the same, Liam. no results.

  2. #22
    Is the app EVER going to get fixed. It kills me that I can't get in to help my fellow Township mayors out!

  3. #23
    I’ve been having this same issue for the last few days too. I tried reinstalling the app on my iPhone and nothing. It’s working on my iPad but I can’t carry that everywhere

  4. #24
    New Member
    Join Date
    Nov 2019
    Posts
    5
    I have this issue since Halloween.

  5. #25

    Township not loading

    Quote Originally Posted by Anarchy chicken View Post
    IOS user, trying to open game, but can’t get it to completely load!!
    Should I uninstall then reinstall?

  6. #26
    Same problem. Mine tries to load then kicks me out.

  7. #27
    Started last Friday, township app tries to load, then stops and disappears to background and all I see is my homepage,, I have done everything suggested, restarted my phone, made sure it’s fully updated, uninstalled the app and reinstalled it,, I have loads of memory,, and nobody has contacted me! All I have gotten so far are the automatic responses as soon as I send in to playrix! I really want this fixed!

  8. #28
    I see this has been a problem for awhile. I have been playing the game for weeks and for the first time actually closed it instead of minimizing it. When I went to open it later it won't get past the screen that says loading. I deleted it and rebooted my computer, updated my computer and checked to be sure I have the latest version of the game. FRUSTRATING as I have spent more money on it than I care to admit!
    how did you all fix your issue?

  9. #29
    Gold Member _DD_'s Avatar
    Join Date
    Jul 2016
    Location
    Germany
    Posts
    8,978
    Quote Originally Posted by Donna Mae Rasmussen View Post
    I see this has been a problem for awhile. I have been playing the game for weeks and for the first time actually closed it instead of minimizing it. When I went to open it later it won't get past the screen that says loading. I deleted it and rebooted my computer, updated my computer and checked to be sure I have the latest version of the game. FRUSTRATING as I have spent more money on it than I care to admit!
    how did you all fix your issue?
    I have replied to your other post. As you're playing on MAC, it might be different anyway.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •