Results 1 to 5 of 5

Thread: My old iPad won't take the new update. Locked out of game. What can I do?

  1. #1

    My old iPad won't take the new update. Locked out of game. What can I do?

    How do I get my game to open on my old iPad. It's highest level of iOS that it takes is 10..... so it can never take the new operating system for iPad. So, because of that, it won't take the new township update. The game will not open for me. Are there any work arounds?

  2. #2
    Hi Kim

    My iPad is an old version, using IOS 9.3.5 and I have completed the new township update with no problem. Perhaps you need to check how much GB is available and maybe delete something to allow space for the township update if there is not enough? Good luck!
    Love makes everything grow more beautiful

  3. #3
    There is nothing remaining to delete. I've even taken Facebook and twitter off that old iPad. It says I have 5.37 GB remaining storage. How much is needed for the Update?

  4. #4
    Current system requirements can be found here, on Playrix's Support pages. Check both your free storage and your RAM.

  5. #5
    Kim, you have plenty GB for the update. I update via App Store icon - updates. Always easy to do. If this is what you did and it's still not working, it probably wouldn't hurt to uninstall and then reinstall. Your current game is saved by Playrix until you can open it again on your old device or a new one.
    Love makes everything grow more beautiful

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •