Results 1 to 4 of 4

Thread: Homescapes on Ipad: Stuck on loading screen

  1. #1

    Homescapes on Ipad: Stuck on loading screen

    Hello community!

    I hope someone can help me, since my Girlfriend and I are the biggest Homescape fans.
    Our Ipad went off when we were winning a level, caused by the low battery.

    After this event Homescapes won't load anymore. It is always stuck at the very first screen where the green loading bar is.
    Just 2mm away from the word "loading".

    I tried to uninstall the game, reinstall it. Restart the Ipad, then reinstall the game.
    I also used the factory reset, but with no help.

    Then I also tried using different ways of deleting Homescapes and I also tried using different Apple-IDs just to get it working.



    Do you have any solution for us?

  2. #2
    I have no idea, but maybe you should make another appleID or something (if you're on IOS) and then download the game again. I don't know, maybe it works?

  3. #3
    Hi there!
    Sorry to hear that you've faced this issue!
    Could you please contact our Support team via this link: https://playrix.helpshift.com/a/home...=web&contact=1
    Our agents will be happy to help!

  4. #4
    Repower iPad. I had this problem but now I'm ok on level 104

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •