(I recently submitted this message to support, but I am reposting it here to see if there are other people facing this issue).

I'm writing because a couple of minutes ago I tried launching the Homescapes ap on my Iphone, and instead of prompting the main menu with the options to play or connect through facebook, it immediately started showing an intro cinematic (which I had never seen before) of the game. To my surprise, once it finished, I saw Austin entering the house (in game graphics now) with no progress on it whatsoever. Austin enters the barren house and makes some remark about the old rug. After that, the game starts, but in what I believe to be level 1. I now suspect that all my progress has been lost.

I haven't made any changes to the phone or the game since the last time I played (which was actually no more than two hours before this happened). I am quite upset as I was around level 365 (I was working on the greenhouse). I have tried relaunching the game several times to no avail. I haven't dared to play the first level either as I do not wish my former progress to be written over, in any case that it still exists. My game was not connected via facebook.

Is there anything we can do about this? Has this anything to do with any latest updates? Has anyone else run into this problem?

Thanks in advance. Regards,