Page 2 of 6 FirstFirst 1234 ... LastLast
Results 11 to 20 of 58

Thread: Dec 2017 (iOS/Android/Kindle) Update: Mine Is Broken!

  1. #11
    Gold Member scorekeeper's Avatar
    Join Date
    Jul 2016
    On a Ridge, Southern Ohio, USA
    1billion picks for 1 coin, what a deal!!

    Definitely a major glitch. Hopefully, they will answer your in-game complaint as soon as possible.
    Game Name: This Is It
    Town Name: Hank
    Town Level: 178
    Platform: Kindle Fire
    I'm Loving Memory of My Dear Friend and a founding Member of The Bonkers and Sucker's Spending Club: Love You, Kim

  2. #12
    Junior Member
    Join Date
    Jan 2017
    I am unable to add a screenshot here( says .png format not accepted), but the dealer is offering picks to me for 21 billion coins , I think( has 10 digits). The number of picks on offer is too tiny for me to see.
    Coop: The Outtatowners
    Level: 141
    Town : Hobo Deeps
    Device: iPad
    Friend code: WKN9UD ( have reached max on friends but happy to stay on your waiting list)
    Coop code: #HEJHQD
    We are open to new players joining. Requirements are minimum of 16 tasks at 135 points per task. If you are interested please private message me letting me know your level. We communicate via LINE chat. Member levels are from 50+

  3. #13
    I have the same problem after i have bought from dealer tools of mine. And I play on IOS.

  4. #14
    I'm in the middle of the regatta with a ton of smelting tasks, and I can't use my mine. I can't get a response from support on my iPad or iPhone other than "try reloading" which I have done repeatedly. They don't even respond to my iPad complaint. If this were truly a FREE game, I'd get it, but I have spent a small fortune over the past year, and for something that I have paid for, the customer service is just not appropriate!

  5. #15
    If you read it correctly it says x-68219511, it means you are buying minus picks BEWARE DO NOT BE FOOLED!!!

  6. #16
    Junior Member
    Join Date
    Jun 2017
    Sorry to hear that you have a problem.
    May i ask if you can still use dinamite and TNT or this is also not working?

    I can also suggest to use the dealer to buy the ore until your problem is fixed.

  7. #17


    Quote Originally Posted by Jajus100 View Post
    I tried buying pick axes from the market. The middle one was marked as one coin. When I go into the mine, it says I have NEGATIVE 1,355,151, 222 pick axes!!! It won't let me do anything. I should have around 100... I have entered an in game ticket.
    I went to purchase pick axes and first it showed like 8 million plus for only a .01, tried to purchase and it said “you don’t have enough space in your barn”, which is odd because mine tools don’t take up barn space. Then I tried again and I guess it was a negative number of pick axes and now I have over 6 million negative in my mine! Prior to this I had over 100. I submitted a ticket, I really hope they fix it.

  8. #18
    Yeah this is pretty much the only game I play on my phone— if this doesn’t get fixed I’m going to be soooo upset!!!

  9. #19
    Just wanted to chime in that I am having the same problem.
    I am playing iOS on phone and the numbers on the crate were so tiny that it was indecipherable. Handed to husband and asked, "Can you read what this says?!"

    He tried to zoom in and accidentally purchased the item, which was something like "- 758, 180, 963 pick axes".
    Tools received from trains are making a small dent in the deficit and dynamite and TNT still work, but at this rate I will never be able to mine effectively again.

    I contacted customer support yesterday afternoon, but so far there has been no response.
    Even a message that they know about the problem and are working on a solution would be reassuring.

    With mining tasks in this regatta, I recommend warning co-op friends to be extremely careful about mining tool purchases at the market!

  10. #20
    Yes, I can still use dynamite and TNT, but that is really inefficient. The fact that the company isn't responding is really bad...

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts