Page 3 of 7 FirstFirst 12345 ... LastLast
Results 21 to 30 of 65

Thread: Update Preventing Game From Loading - November 2017

  1. #21
    same problem here.... update won't load and i can't get back into my town 😄 any suggestions please?

  2. #22
    There's another thread going about this. What worked for me was uninstalling the game and then reinstalling (stay connected to Facebook or Google Play) I don't usually have a problem!

  3. #23
    Already turned on

    This is 3 out of last 4 updates

  4. #24

  5. #25
    Help! Opening screen just displays DOWNLOAD, can’t get rid of it. App Store says the game is already downloaded. What do I do??

  6. #26
    None of this should be happening

    Switching off doesnt achieve anything either

    Just go round in circles

    Because reinstalling works for one doesnt mean it works for all

    Not prepared to risk it and my t cash too

    They never seem to have a problem shovelling t cash offers do they

    The update isnt in the app store just the halloween one which is done

    So how long we gonna be locked out this time
    Last edited by Firenze; 11-09-2017 at 08:24 PM. Reason: Merged

  7. #27
    Member Firenze's Avatar
    Join Date
    Jun 2017
    Location
    San Diego, USA
    Posts
    392

    Lightbulb Things to Try if Update Isn’t Loading

    iOS users see this post too

    Hello all! Very sorry to hear about the update issues.

    Please remember that the forums are mostly used by other players; we cannot fix anything for you — you must contact Playrix. There are a few things you can try to help yourself, though, so see below...

    Don’t see an update at all? The updates roll out differently for everyone so if you don’t have it yet, check your internet connection, restart your device, and be patient. Maybe even try the ideas below.

    Update taking forever to load? Graphics still loading? When you make an update, even after it downloads you may be able to launch the game, but graphics may still take some time to load. If it says “graphics still loading,” this is probably not a glitch, but simply the game taking time to finish. Be sure your Internet connection is working well and give it some time.

    >>> If you are having OTHER issues like it won’t load at all or the game stopped working or crashes, try as much of the following as you can:

    1. To be sure your device meets minimum system requirements, click here.
    - If you don’t have enough memory, it will not update.
    - You may also need to update your device’s software to the latest operating system.

    2. Restart your device. Be sure it’s connected to the internet.

    3. If that doesn’t fix your problem and if you can do so:
    - Take screenshots of your friend code and level/T-cash/coins.
    - Connect your game to Facebook, Google, or Game Circle (depending on your device) to back up your town.
    - Delete the app. Install Township again. Reconnect to your social account.

    Note: If you don’t already do so, it’s a good idea to keep photos of your friend code, tcash, and receipts anyway in case of this kind of issue or others.

    4. If all of the above doesn’t work, take screenshots of your issue (screen blank or loading, etc) and send them along with any Town-identifying screenshots to Playrix. Be sure to include your details and screenshots and reply to every message they send you, even automated ones, to keep your support ticket open.

    >>>If you can access the Help section in the game, USE THAT and click the Contact Us option because it will help Support to find you faster.
    >>> If that method won’t work because you are locked out, use this form.

    5. Please come back here to tell us what worked. If it didn’t work, please come back and tell us your support ticket number or friend code. This will allow us to send the thread to admin and they can check on your tickets with that information.

    GOOD LUCK!!!
    Last edited by Firenze; 11-10-2017 at 02:14 AM. Reason: Added link
    Town: Firenze, iOS (KN74NX), Level 90
    Co-op Leader: Aphrodite's Piers (#PHY68K)

  8. #28
    I cannot load the update either...I have most recent iOS version... I’m very annoyed because I have a boost on my heli and can get on the game to use it...on iPhone or ipad

  9. #29
    I had similar problem on android and the problem was there was not enough memory in my devise.

  10. #30
    Seeing as i cant get into the game at all its gonna be a bit hard to take screen shots

    Sames gos for checking its logged into facebook which it should be

    Ive just stocked with t cash and im not gonna risk losing that by reinstalling

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •