Page 1 of 7 123 ... LastLast
Results 1 to 10 of 65

Thread: Update Preventing Game From Loading - November 2017

  1. #1

    Update Preventing Game From Loading - November 2017

    Borrowing this first post to add a link for easier navigation. IF YOU ARE EXPERIENCING UPDATE PROBLEMS, SEE THIS POST before commenting. Thank you!

    Hi since the latest update when I load the game on my Android tablet the game hangs on the startup screen. The only way I can get it to load is to clear cache. Also the game is running slower and slower with every update
    Last edited by Firenze; 11-09-2017 at 09:47 PM. Reason: Borrowed first post to add Mod note/link to help instructions

  2. #2
    Check your Android version two years ago I was playing on an older tablet and mine did the same thing found the table was not updating had to purchase a new one. The minimum requirements are posted within the game under help just don't have them available or I would post.
    **Started playing August 2015** Town 135 Zoo 45 FINALLY
    Have all the factories Special projects and land expansion Zoo IS DONE
    In a small Golden League co-op 5 of us no drama we have fun
    #QM25Q2 come visit Guinn Township
    Android Tablet and phone

  3. #3

    Update not loading

    Im on Ios

    Here we are again game not loading locked out

    Tried from app store updated just goes round in circles and the update is still the halloween one

    We pay all this money to play then we have this fiasco every few weeks
    Last edited by Felinefeline1; 11-09-2017 at 06:53 PM.

  4. #4
    I had to delete and then reinstall the game to get my iOS update, since it wasn’t showing in AppStore. Couple minutes, problem solved for me.
    As Township Moderators, we maintain the forum according to its rules. We are not Playrix Staff
    - How to contact Township Support
    - Co-op Ads thread, co-ops seeking new members may advertise their team here.
    - Player Ads thread, individuals seeking a co-op may advertise themselves here.

  5. #5
    I'm having the same problem-on mini-Ipad 4-download button in game takes me to app store but there is no install button?

  6. #6
    Hmmm well no guarantee if you delete it you will get it back

    Becoming a joke nearly every update

    Just stocked up with t cash

    Lose the game lose that too

    What a way to go on keep expect people to reinstall

    Why not test it before hand

    Ipad air 2

  7. #7
    The update is not loading and I can’t get back in to my town.

  8. #8
    Found the solution-go to your device settings and turn onn automatic updates-then when you go to the app store the update button will appear-

  9. #9
    Already turned on

    This is 3 out of last 4 updates

  10. #10
    I had the problem just now with my IOS 10 mini-ipad-I went to Playrix support online and it said goo to your Settongs on your device and turn on Automatic updates-I did this and then the App Store update was visible for the game-

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts