Results 1 to 3 of 3

Thread: Android Problems

  1. #1
    Junior Member
    Join Date
    Aug 2016

    Android Problems

    I downloaded Homescapes from Google Playstore earlier today, played a level but then quit, but now I can't get the game to open again. I have uninstalled and reinstalled but nothing works. Now I just tried again and it says external storage unavailable. I do have an SD card but don't use it for game data. Not sure what else to do.

  2. #2
    New Member Connie Sychowski's Avatar
    Join Date
    Jun 2017
    Northwest USA
    Have you tried restarting the device?? Sometimes that is the simplest fix that works

  3. #3
    Senior Member Honor's Avatar
    Join Date
    Apr 2017
    Midwestern USA
    I haven't downloaded Homescapes yet, but I have a few ideas from Gardenscapes:

    First, make sure you have the minimum requirements (may be different for Homescapes but it's a start!)
    - 1GB of RAM
    - 500 MB of free space
    - stable internet connection

    Next, try clearing the cache:
    1. Go to device settings > Applications.
    2. Select Gardenscapes in the application list.
    3. Find the Clear Cache button, tap it, and reenter the game.

    If you still can't get into the game, you can use this link to start an email convo with support (scroll to the bottom):

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts